Forum Settings
       
Reply To Thread

ZAM Soul Calculator not Working?Follow

#1 Jul 09 2012 at 4:25 PM Rating: Decent
4 posts
http://i31.photobucket.com/albums/c391/steveyk/soultree.jpg

The site is whitelisted and I have updated Java to the latest version, chrome updates itself and firefox and Internet explorer is up to date but the skill tree still looks like this in every browser. The tree is completely blacked out.

Can anyone help me here?
#2 Jul 09 2012 at 5:36 PM Rating: Excellent
The Great Pretender
ZAM Administrator
Avatar
****
6,626 posts
Hrm, it's working for me. What browser are you using? Have you cleared your cache lately?
____________________________
User Image
ZAM QA Lead
EverQuest II || Free Realms
My Non-Gaming Blog
I see rude people.
#3 Jul 12 2012 at 2:38 AM Rating: Decent
4 posts
It happens on all my browsers (chrome, firefox and Internet explorer) I don't use internet explorer at all so it's not the cache. I emptied the caches anyway just in case. It may be a problem with java though. if it is in java that is. This is kind of irritating as everyone uses this soul tree calculator and I can't even see it.
#4 Jul 12 2012 at 8:38 AM Rating: Excellent
Empress of News
ZAM Administrator
Avatar
***
2,161 posts
I went directly to the link in your picture (next time please include that, that took quite a while to type out!! .. was trying to see if the build itself was broken, which it's not), while logged out with ads whitelisted, and had no problems seeing the build on Firefox 13.0.1. I also had updated my java yesterday to the latest version as well. Since we are obviously using a similar Firefox setup, do you possibly have any other add-ons that could be causing this?
#5 Jul 12 2012 at 3:10 PM Rating: Decent
4 posts
Sorry but I should have included that its not just that one link it's all links and builds and even trying to create one myself. That's why I never included that link. It just doesn't load. Like I said this is in all browsers so it's not an actual add-ons problem as I of course don't have the same addon on all browsers. Although I did disable addons just in case with no luck. All my browsers are up to date like I also said so I have 13.0.1 also. I have also recently tried disabling my firewall (zone alarm) and that didn't work either. That image by the way was from chrome.
#6 Jul 12 2012 at 3:24 PM Rating: Decent
4 posts
Now that I think about it, when you loaded the soul calculator did the java icon load up in your task bar to tell you Java was running? If it did then we are getting somewhere because mine isn't loading up.
#7 Jul 12 2012 at 6:08 PM Rating: Excellent
The Great Pretender
ZAM Administrator
Avatar
****
6,626 posts
steveyk wrote:
Now that I think about it, when you loaded the soul calculator did the java icon load up in your task bar to tell you Java was running? If it did then we are getting somewhere because mine isn't loading up.

Nope.
____________________________
User Image
ZAM QA Lead
EverQuest II || Free Realms
My Non-Gaming Blog
I see rude people.
#8 Jul 16 2012 at 6:03 PM Rating: Excellent
Empress of News
ZAM Administrator
Avatar
***
2,161 posts
steveyk wrote:
Now that I think about it, when you loaded the soul calculator did the java icon load up in your task bar to tell you Java was running? If it did then we are getting somewhere because mine isn't loading up.

No I don't see that either.
#9 Jul 24 2012 at 2:34 PM Rating: Decent
1 post
Any news on this problem?
Only asking because I have had the same problem for the past week or so, prior I have never had any issue with viewing the soul calculator. Out of no where it began doing the exact same thing to me, just a blank black screen with no information I cant figure out what is wrong.
#10 Jul 24 2012 at 7:09 PM Rating: Excellent
The Great Pretender
ZAM Administrator
Avatar
****
6,626 posts
Gaffan wrote:
Any news on this problem?
Only asking because I have had the same problem for the past week or so, prior I have never had any issue with viewing the soul calculator. Out of no where it began doing the exact same thing to me, just a blank black screen with no information I cant figure out what is wrong.


It's not something any of us have been able to reproduce, making it really hard to fix.

1) clear your cache
2) update your java

Then if its still not working post which browser (and which version of that browser) you're using, with as much info as you can to help us run it down.
____________________________
User Image
ZAM QA Lead
EverQuest II || Free Realms
My Non-Gaming Blog
I see rude people.
#11 Oct 28 2012 at 7:25 PM Rating: Decent
2 posts
Having issues with it also, Useing either Safari on my Ipad, Chrome Version 22.0.1229.94 m or Firefox
Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
#12 Oct 28 2012 at 7:54 PM Rating: Excellent
The Great Pretender
ZAM Administrator
Avatar
****
6,626 posts
Skithus wrote:
Having issues with it also, Useing either Safari on my Ipad, Chrome Version 22.0.1229.94 m or Firefox

Please clear your cache and update your java as linked above, and if the problem reoccurs post specifics. Thanks!
____________________________
User Image
ZAM QA Lead
EverQuest II || Free Realms
My Non-Gaming Blog
I see rude people.
#13 Oct 31 2012 at 9:27 AM Rating: Good
Avatar
***
2,503 posts
This is occurring for me as well... my java is up to date and my cache clears every time I close Chrome.

What specifically is happening is that when I click a branch to add points to it, the branch goes up to 5 (or whatever) and then nothing else happens.. None of the roots unlock and the next tier of branches don't unlock.

It's super goodsauce #1 if you want a 10 point build... and bad at all other times.

Edited, Oct 31st 2012 10:28am by Callinon
____________________________
svlyons wrote:
If random outcomes aren't acceptable to you, then don't play with random people.
#14 Nov 02 2012 at 10:47 AM Rating: Decent
2 posts
Archmage Callinon wrote:
This is occurring for me as well... my java is up to date and my cache clears every time I close Chrome.

What specifically is happening is that when I click a branch to add points to it, the branch goes up to 5 (or whatever) and then nothing else happens.. None of the roots unlock and the next tier of branches don't unlock.

It's super goodsauce #1 if you want a 10 point build... and bad at all other times.

Edited, Oct 31st 2012 10:28am by Callinon


This is the exact issue I'm having.
#15 Nov 02 2012 at 11:36 AM Rating: Decent
1 post
I am also having the same problem as Callinon. It only started recently with patch 1.11 and never had the problem before.
I cleared my cache, updated java, reopened firefox and instantly went to here and it's not letting me go to a higher tier in the talent calculator.
When looking at the error console of firefox I seem to be getting 1 error and a whole lot of warnings.
This is the error I get:
Timestamp: 2-11-2012 18:01:13 
Error: SyntaxError: XML can't be the whole program 
Source File: http://mb.zam.com/mb/b?s=1663&size=25&id=7562673284248188944&tr=http%3A//rift.zam.com/en/stc.html%3Ft%3D00___&pc=rift%20ZAM%20Other&ri=120&wrap=jspure 
Line: 2


And this are a couple of examples of the warnings (there are well over 100 warning from just going to the cleric tank calculator selecting justicar in the middle soul and putting 5 points in the lowest 2 talents):
Timestamp: 2-11-2012 18:01:13 
Warning: Expected declaration but found '*'.  Skipped to next declaration. 
Source File: http://zam.zamimg.com/rift/c/site.css?181 
Line: 898


Timestamp: 2-11-2012 18:01:13 
Warning: An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing 
Source File: http://rift.zam.com/en/stc.html?t=00___ 
Line: 38


Timestamp: 2-11-2012 18:01:13 
Warning: Error in parsing value for 'background-position'.  Declaration dropped. 
Source File: http://zam.zamimg.com/c/tooltips.css?5 
Line: 122


Timestamp: 2-11-2012 18:01:13 
Warning: Expected declaration but found '*'.  Skipped to next declaration. 
Source File: http://zam.zamimg.com/c/tooltips.css?5 
Line: 440


Timestamp: 2-11-2012 18:01:14 
Warning: Unknown property '-moz-outline-style'.  Declaration dropped. 
Source File: http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Frift.zam.com%2Fen%2Fstc.html&layout=button_count&show_faces=false&width=450&action=like&colorscheme=dark&locale=en_US 
Line: 9


Timestamp: 2-11-2012 18:01:14 
Warning: Selector expected.  Ruleset ignored due to bad selector. 
Source File: http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Frift.zam.com%2Fen%2Fstc.html&layout=button_count&show_faces=false&width=450&action=like&colorscheme=dark&locale=en_US 
Line: 5


Timestamp: 2-11-2012 18:01:14 
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead. 
Source File: chrome://wrc/content/overlay.js 
Line: 1105


Timestamp: 2-11-2012 18:02:10 
Warning: Expected declaration but found '*'.  Skipped to next declaration. 
Source File: http://forums.riftgame.com/css.php?styleid=1&langid=1&d=1349108555&td=ltr&sheet=bbcode.css,editor.css,popupmenu.css,reset-fonts.css,vbulletin.css,vbulletin-chrome.css,vbulletin-formcontrols.css, 
Line: 299


Timestamp: 2-11-2012 18:02:10 
Warning: Expected end of value but found '424b89'.  Error in parsing value for 'border'.  Declaration dropped. 
Source File: http://forums.riftgame.com/css.php?styleid=1&langid=1&d=1349108555&td=ltr&sheet=bbcode.css,editor.css,popupmenu.css,reset-fonts.css,vbulletin.css,vbulletin-chrome.css,vbulletin-formcontrols.css, 
Line: 1131


Timestamp: 2-11-2012 18:02:10 
Warning: Expected end of value but found '%'.  Error in parsing value for 'background'.  Declaration dropped. 
Source File: http://forums.riftgame.com/css.php?styleid=1&langid=1&d=1349108555&td=ltr&sheet=attachments.css,forumbits.css,forumdisplay.css,postlist.css,projecttools.css,threadlist.css,usercp.css,postbit.css,private.css 
Line: 1440


At the end this is what the talent calculator looks like for me:
http://i.imgur.com/9SmPM.png
#16 Nov 02 2012 at 3:06 PM Rating: Decent
1 post
The error has nothing to do with Java. It is a JavaScript error. Telling people to update their Java installation is misinformation.

While their names sound similar, they are completely different things:

Java.
JavaScript

The errors are the result of something wrong with Zam's Soul Calculator -- there's a bug in Zam's code.

A quick look using Firebug results in these JavaScript errors when trying to add a point into an soul talent.

TypeError: soulTTI[soul] is undefined
http://zam.zamimg.com/rift/j/site.js?74
Line 117


#17 Nov 07 2012 at 11:19 AM Rating: Excellent
The Great Pretender
ZAM Administrator
Avatar
****
6,626 posts
It's often a valid fix when the issue is on the user-side. I'm pinging acprog for this one, as it seems to be a different issue.
____________________________
User Image
ZAM QA Lead
EverQuest II || Free Realms
My Non-Gaming Blog
I see rude people.
#18 Nov 07 2012 at 11:32 AM Rating: Excellent
$title{308642}
*****
0X317A posts
-edit- should be fixed now. Combination of a couple issues, one of which being my fault dealing with new perks, the other being the data had abilities with negative IDs for some reason that broke some things. Removed those.

Edited, Nov 7th 2012 12:46pm by acprog
____________________________
Since 1 March 2004

Rift Signature
#19 Nov 07 2012 at 2:17 PM Rating: Excellent
$title{308642}
*****
0X317A posts
So it turns out that those negative IDs are a new thing and valid. Just pushed an update to handle them. Let me know if you find any other brokenness (of the non-css-warning/alert messages; just JS, please).

Thanks!
____________________________
Since 1 March 2004

Rift Signature
#20 Nov 08 2012 at 3:01 PM Rating: Good
Avatar
***
2,503 posts
Appears to work properly now, thanks Smiley: smile
____________________________
svlyons wrote:
If random outcomes aren't acceptable to you, then don't play with random people.
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 12 All times are in CDT
RajiFarlander, Anonymous Guests (11)